I would use
reportMissingData
Agreed, report
feels clearer as the verb “record” is more about permanent storage and later reference.
Or even just reportMissing
? Depending on what’s happening around call sites, I often find I can drop generic stuff like “Data” and it’s just as clear, especially when looking at a function signature.
For instance:
func reportMissing(data) { ... }
I found the documentation extremely lacking last time I looked at Swift 2 or 3 years ago. Any changes there? Or perhaps there’s somewhere outside of Apple’s own docs I should have been looking?